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[bookmark: _Toc68776025]ERCOT System Protection Working Group Scope
· [bookmark: _Toc129674697]The ERCOT System Protection Working Group (SPWG) operates under the direction of the Reliability and Operations Subcommittee (ROS). The SPWG is a non-voting working group whose members include representatives from ERCOT Transmission Service Providers (TSPs) and ERCOT staff.  SPWG responsibilities related to case building are further described as follows:
· Develop and maintain short circuit base case for the current year.  The case, collectively known as Current Year (CY) base case, is produced by the SPWG by approximately April 1st on an annual basis.
· Develop and maintain short circuit base case for the future years. The cases, collectively known as Future Year (FY) base cases, are produced by the SPWG by approximately July 1st on an annual basis.
· Review and update, as necessary (at least every five years), the SPWG Procedural Manual to reflect current planning practices and the latest short circuit base case modeling methodologies.
[bookmark: _Toc68776026]Introduction to Short Circuit Case Building Procedures and Methodologies
· The principal function of the SPWG is to provide ERCOT system current year and future year short circuit models, or base cases, which contain appropriate equipment characteristics, system data, and shall represent projected system conditions.  This procedure manual is intended to demonstrate compliance with NERC Reliability Standards applicable to short circuit modeling. 
· Short Circuit models are bus-branch representations of the high voltage transmission system (60 kV and above), which includes buses, branches, impedances, reactive devices, transformers, generators, and DC lines.
· The ROS directs the SPWG as to which base cases are to be created. Currently, the SPWG builds CY and FY base cases on an annual basis.

[bookmark: _Toc68776027]System Protection Base Case Building
[bookmark: _Toc68776028]Overview
· ASPEN OneLiner has been chosen by System Protection Working Group (SPWG) as the software package for building the ERCOT system current year and future year short circuit base cases. Previously, SPWG used PSS/E to build all the short circuit base cases which was discontinued after 2010 future year short circuit base case building.
· Before starting the case building process, ERCOT & SPWG members are required to be using the same ASPEN & PSS/E versions. SPWG shall decide at the November SPWG Meeting which ASPEN & PSS/E version will be used for the next year case building process.
· Short circuit base cases are created in two categories:
· Current Year (CY)
· Future Years (FY): Five years following the current year i.e. CY+1, CY+2, CY+3, CY+4, and CY+5
· Example: For the calendar year 2016, the following short circuit cases will be created, namely: 2018 CY case, 2019 FY, 2020 FY, 2021 FY, 2022 FY, & 2023 FY cases.
· Members’ short circuit base case data shall be submitted reflecting the following conditions:
· All equipment expected to be in-service by June 30th of the case year shall be included in the case.
· All generator units that meet the requirements of ERCOT Planning Guide Section 6 shall be modeled in the appropriate case.
· Mutual impedance effects should be included.  For more details, refer to section 1.9.
· The system base shall be 100 MVA.
· For those members who don’t have/use ASPEN, they may submit the files in PSS/E. No other format is acceptable.
· For the 2021 case building process, SPWG has agreed to use ASPEN v14.8 and PSS/E v33. If SPWG members do not have the appropriate versions installed on their systems, then they will need to upgrade to the acceptable versions as determined by SPWG for building the short circuit cases.
· All the ASPEN and PSS/E files which are submitted to ERCOT should be compatible with the above agreed versions.
[bookmark: _Toc68776029]File Naming Convention
· The following file naming convention shall be followed by SPWG members & ERCOT members when submitting the files to ERCOT. No other file naming convention is allowed.
NOTE:
· AAA		= Letters representing the Company Acronym.
· BB		= 2-digits representing the year of the case build.
· CCCC		= 4-digits representing the year the changes are to be applied to.
· XX		= 2-letters, “CY” for Current Year or “FY” for Future Year.
· N		= 1-digit representing the pass number. For Final Pass, N = “Final”.
· MMDDYYYY	= Representing the posting date of the specific case build period.

ASPEN Change File Creation Naming Convention
· General File Naming Convention:
· AAA_BB_SPWG_CCCC_XX_PassN.CHF
· Example: If AEP is submitting their 2022 FY Pass2 case changes to ERCOT then the change file name should be as follows:
· AEP_21_SPWG_2022_FY_Pass2.CHF
PSS/E File Naming Convention
· General File Naming Convention:
· AAA_BB_SPWG_CCCC_XX_PassN.{RAW or SEQ}
· Example: If CNP is submitting their 2022 FY Pass2 case changes to ERCOT then the PSSE file names should be as follows:
· CNP_21_SPWG_2022_FY_Pass2.RAW
· CNP_21_SPWG_2022_FY_Pass2.SEQ
· For members submitting the data in PSS/E format, the RAW file should have a “.raw” extension and the SEQ file should have a “.seq” extension.  Members need to send in “re-change” raw files to prevent ERCOT from having to manually adjust member-submitted files.
ERCOT Log File Naming Convention for Converting PSSE to ASPEN
· General File Naming Convention (when converting members’ files):
· AAA_BB_SPWG_CCCC_XX_MMDDYYYY_PassN_conversion_log.TXT
· Example: If ERCOT is converting AEN 2022 FY Pass2 PSSE .raw and .seq case changes to an ASPEN .DXT file, then the conversion log name should be as follows:
· AEN_21_SPWG_2022_FY_05212021_Pass2_conversion_log.TXT
ERCOT Change File Creation Naming Convention
· General File Naming Convention (when converting a member’s file):
· AAA_BB_SPWG_CCCC_XX_PassN.CHF
· Example: If ERCOT is converting AEN 2022 FY Pass2 DXT file to an ASPEN change file, then the change file name should be as follows:
· AEN_21_SPWG_2022_FY_Pass2.CHF
· General File Naming Convention (when consolidating all change files):
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_consolidated.CHF
· Example: if ERCOT is consolidating all 2022 FY Pass2 change files received from members, then the consolidated change file name should be as follows:
· 21_SPWG_2022_FY_05212021_Pass2_consolidated.CHF
ERCOT Change File Creation Log Naming Convention
· General File Naming Convention (when converting a member’s file):
· AAA_BB_SPWG_CCCC_XX_PassN_change_log.TXT
· Example: If  ERCOT is converting AEN 2022 FY Pass2 DXT file to an ASPEN change file, then the change file log name should be as follows:
· AEN_21_SPWG_2022_FY_Pass2_change_log.TXT
· General File Naming Convention (when consolidating all change files):
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_consolidated_log.TXT
· Example: If ERCOT is consolidating all 2022 FY Pass 2 change files received from members, then the consolidated change log file name should be as follows:
· 21_SPWG_2022_FY_05212021_Pass2_consolidated_log.TXT
ERCOT Change File Naming Convention 
· General File Naming Convention:
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_import_log.TXT
· Example: If ERCOT is compiling the 2022 FY Pass2 case from the changes received from TSPs then the case build name should be as follows:
· 21_SPWG_2022_FY_05212021_Pass2_import_log.TXT
ERCOT Case Build File Naming Convention 
· General File Naming Convention:
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN.DXT
· Example: If ERCOT is compiling the 2012 FY Pass2 case from the changes received from TSPs then the case build Name should be as follows:
· 21_SPWG_2022_FY_05212021_Pass2.DXT
· The Updated date in the above file name is the date on which ERCOT compiles all the changes received from TSPs.
[bookmark: _Toc68776030]Converting PSSE Files to ASPEN *.DXT Format
· For members who don’t have/use ASPEN, ERCOT has agreed to accept PSS/E files from those companies. 
· As mentioned in the above section, any PSS/E files submitted to ERCOT should follow the file naming convention and also should be in the same PSS/E version as described before. If members do not submit in the correct PSS/E version, then when converting from PSS/E to ASPEN the data may not be converted correctly.
· PSS/E “.raw” files should be created using the “Configure RAW file to” option “Use with RDCH”.
[image: ]
[bookmark: _Toc68769589][bookmark: _Toc68776111]Figure 1: PTI PSS/E-ASPEN Conversion RAW data Save Network Data Screenshot
[image: ]
[bookmark: _Toc68769590][bookmark: _Toc68776112]Figure 2: PTI PSS/E-ASPEN Conversion Sequence Data Save Network Data Screenshot

· Once ERCOT receives the PSS/E files, then ERCOT will use the PTI PSS/E-ASPEN conversion utility program provided by ASPEN to convert PSS/E files to ASPEN *.DXT format.
· The PTI PSS/E-ASPEN conversion program can be accessed through Program Files > ASPEN OneLiner > PTI PSS/E-ASPEN
· After you open the PTI PSS/E-ASPEN conversion program, go to File > Convert. Once you click on the Convert link, it will open a popup window where you can select the raw file which needs to be converted. The following screenshot shown below is for reference.
[image: ]
[bookmark: _Toc68769591][bookmark: _Toc68776113]Figure 3: PTI PSS/E-ASPEN Conversion Raw File Selection Screenshot

· After an appropriate *.raw file is selected for conversion, the conversion utility program will ask to confirm the PSS/E version along with another option, where you can select if you need to read the *.seq file also. For converting PSS/E to ASPEN format, both the*.raw & *.seq files must be read. See the screenshot for reference.
[image: ]
[bookmark: _Toc68769592][bookmark: _Toc68776114]Figure 4: PTI PSS/E-ASPEN Conversion File Options Screenshot
· Once the option to read *.seq file is selected, conversion program will provide you with another popup window where the user can select the appropriate *.seq file. See the screenshot for reference.
[image: ]
[bookmark: _Toc68769593][bookmark: _Toc68776115]Figure 5: PTI PSS/E-ASPEN Conversion Seq File Selection Screenshot
· After the appropriate *.seq file is selected for conversion, the ASPEN conversion program will prompt the user with a save window where you need to enter the file name by following the file naming conventions which are described in previous section. See the screenshot for your reference.
[image: ]
[bookmark: _Toc68769594][bookmark: _Toc68776116]Figure 6: PTI PSS/E-ASPEN Conversion Save Converted File Screenshot

· After the user enters the file name and clicks the “Save” button then the ASPEN PTI PSS/E-ASPEN conversion program will prompt the user with the conversion options. The following screen shot will show what options and check boxes ERCOT will be using when converting the PSS/E files to ASPEN *.DXT format. Any ERCOT personnel who is building the short circuit case and who would like to convert PSS/E files to ASPEN *.DXT format should use the following options as shown in the screenshot below.
[image: ]
[bookmark: _Toc68769595][bookmark: _Toc68776117]Figure 7: PTI PSS/E-ASPEN Conversion Options Screenshot

· Once, the user selects the appropriate options as shown above and clicks the “OK” button, ASPEN conversion program will convert the *.raw & *.seq files to ASPEN *.DXT format. When the conversion is done, it creates a conversion log which needs to be saved by following the log file naming conventions which was described in previous section. To save the log file to a text file first select all the data in the window by going to Menu and View > Select All. After the user selected all the data then go to menu View > Save Selected Text to File and the conversion program will prompt the user to enter the file name to which the conversion logs will be saved.
· All the conversion logs should be sent to SPWG members when sending the cases out for their review. These logs will inform the members if any errors are encountered during the conversion process so that the data can be corrected and resubmitted during the next pass.
[bookmark: _Toc68776031]Creating ASPEN Change File (*.CHF)
· When submitting data to ERCOT, SPWG members who use ASPEN for building short circuit cases need to submit the ASPEN Change File (*.CHF) to ERCOT and for members who use PSS/E to build the short circuit cases, ERCOT will create the change files (*.CHF) on their behalf before compiling the case in ASPEN OneLiner, which is created based upon a base case that ERCOT sends to the members before a case is built. This case should only be used when creating the Change File (*.CHF) for Pass0 submissions. All the other change files must be created based upon the previous pass case. For example, if a user is creating a change file for Pass2 then the base case that should be used is the Pass1 case.
· For creating Pass0 change files in ASPEN, members should use the base case which is sent by ERCOT during the initial case building process. For example if we are building the 2021 Current Year (CY) case, then the change file will be made comparing the updated case (with member’s changes) and the 21_SPWG_2021_CY_Pass0 which was provided by ERCOT at the beginning of the 2021 CY case build.
· When building the Future Year (FY) cases in 2021, for the Y+1 (2022) Pass0 ERCOT will use the 20_SPWG_2022_FY_FinalPass from last year’s FY case build as base case and add change files as described in the graphic below. So for the year 2021, ERCOT will use the 20_SPWG_2022_FY_FinalPass (built during 2020 future year case build) as base case and add change files to this case. This process is also shown and described Figure 8.
[image: ]
[bookmark: _Toc68769596][bookmark: _Toc68776118]Figure 8: 2021 Future Year Pass0 Case Build Process Flow

· To create the incremental change file for the year 2021, i.e. the 2021 Changes .CHF (ASPEN change file) is created by comparing the cases 20_SPWG_2021_FY_FinalPass (built last year) and 21_SPWG_2021_CY_FinalPass (built this year). The resulting 2021 Changes .CHF file is then imported to the base case 20_SPWG_2022_FY_FinalPass (built last year) to build the 21_SPWG_2022_FY_Pass0.

· This process is done in a similar fashion for Y+1 through Y+4 for future year case build. The Pass0 for Y+5 is the same as the Pass0 for Y+4. Refer to Table 1 for more details.





Table 1: ERCOT’s Base Case Selection and Process Flow for Creating Pass0
	Comparing File A
	With File B
	To Get Changes
	To Be Imported to Base Case
	To Get

	20_SPWG_2021_FY_FinalPass
	21_SPWG_2021_CY_FinalPass
	2021 Changes
	20_SPWG_2022_FY_FinalPass
	21_SPWG_2022_FY_Pass0

	20_SPWG_2022_FY_FinalPass
	21_SPWG_2022_FY_Pass0
	2022 Changes
	20_SPWG_2023_FY_FinalPass
	21_SPWG_2023_FY_Pass0

	20_SPWG_2023_FY_FinalPass
	21_SPWG_2023_FY_Pass0
	2023 Changes
	20_SPWG_2024_FY_FinalPass
	21_SPWG_2024_FY_Pass0

	20_SPWG_2024_FY_FinalPass
	21_SPWG_2024_FY_Pass0
	2024 Changes
	20_SPWG_2025_FY_FinalPass
	21_SPWG_2025_FY_Pass0

	“21_SPWG_2025_FY_Pass0” is to be copied, renamed, and used for “21_SPWG_2026_FY_Pass0”



· For creating any subsequent change files for Pass1 and beyond, members should apply their changes to the previous pass case (as File A) and save their updated file (as File B) to compare and create the change file (*.CHF) that includes necessary changes to create the next pass. Table 2 will give an example on what base case should be selected when creating a change file (*.CHF) file for Pass1.


Table 2: Base Case Selection for Creating the ASPEN Change Files (*.CHF) for Pass1 and Beyond
	Comparing File A (Base Case)
	With File B (Member’s Changes)
	To Get Changes

	21_SPWG_2022_FY_Pass0
	CompanyName_21_SPWG_2022_FY_Pass0
	CompanyName_21_SPWG_2022_FY_Pass1

	21_SPWG_2023_FY_Pass0
	CompanyName_21_SPWG_2023_FY_Pass0
	CompanyName_21_SPWG_2023_FY_Pass1

	21_SPWG_2024_FY_Pass0
	CompanyName_21_SPWG_2024_FY_Pass0
	CompanyName_21_SPWG_2024_FY_Pass1

	21_SPWG_2025_FY_Pass0
	CompanyName_21_SPWG_2025_FY_Pass0
	CompanyName_21_SPWG_2025_FY_Pass1

	21_SPWG_2026_FY_Pass0
	CompanyName_21_SPWG_2026_FY_Pass0
	CompanyName_21_SPWG_2026_FY_Pass1



· When creating the change files, the naming convention defined in the previous sections should be followed. For example if AEP is creating a change file for Pass2 then the file naming conventions should be as follows:
· AEP_21_SPWG_2022_FY_05212021_Pass2.CHF
· ASPEN Change File (*.CHF) conversion program is located under Program Files > ASPEN OneLiner > Case Comparison. Once you open the Case Comparison program go to File > Open. ASPEN will prompt you with a popup window to select the Base Case File which is either *.DXT or *.OLR file. See the screenshot in Figure 9 for your reference.

[image: ]
[bookmark: _Toc68769597][bookmark: _Toc68776119]Figure 9: ASPEN Case Comparison Open File “A” Popup Window
· Once the base case is selected, ASPEN will prompt to select the updated case file which is file B so that it can create a Change File (*.CHF).
· Note the following relationship: Base Case + Change File = Updated Case. See Figure 10 for your reference.

[image: ]
[bookmark: _Toc68769598][bookmark: _Toc68776120]Figure 10: ASPEN Case Comparison Open File "B" Popup Window
· Once the updated case file is selected, the ASPEN case comparison program will give you another popup window where the following options must be selected before creating the Change File (*.CHF).
· Always create the change file by comparing “Name and kV” as bus names and kV are always unique in the ERCOT system.
· Create the Change file just for your “Area” by selecting the “Inside” Radio Button and populating the required areas for which the change file needs to be created.  Effective beginning with the 2013 short circuit case building process, please note that generator facilities interconnected to a given TSP will have a +900 area number offset from the area of the TSPs interconnection facilities (e.g. area 907 vs. area 7) and those generator facilities should not be included in the change file.
· Also, before finalizing the options make sure you check the “Include ties between selected items and the rest of the network” checkbox as we would like to include the ties in the change file that is being created.
· The following are the options which needs to be selected when creating any Change File (*.CHF) either by SPWG members or by ERCOT. See Figure 11 for your reference.

[image: ]
[bookmark: _Toc68769599][bookmark: _Toc68776121]Figure 11: ASPEN Case Comparison Options Selection Window
· Once, the user selects the appropriate options as shown above and hits the “OK” button, ASPEN comparison program will prompt the user to define a file name for the Change File (*.CHF) log file. The log file naming convention should be followed as mentioned in the previous sections. For example if AEP is creating a Change File (*.CHF) for the year 2022 Pass2 during the 2021 FY case build, then the change file log (*.TXT) file name should be as follows (See Figure 12 for reference):
· AEP_21_SPWG_2022_FY_Pass2_change_log.TXT
[image: ]
[bookmark: _Toc68769600][bookmark: _Toc68776122]Figure 12: ASPEN Case Comparison Save Difference Report (Change Log) Window
· After the user defines the change file log (*.TXT) file name, ASPEN Comparison program will prompt the user with another popup window where the user needs to select the destination and enter the file name for the change file (*.CHF) that has been created by the program. Again, the file naming convention described in the previous section should be followed. For Example if AEP is creating a change file (*.CHF) for the year 2022 Pass2 during the 2021 FY case build, then the file name should be as follows (see Figure 13 for reference):
· AEP_21_SPWG_2022_FY_Pass2.CHF

[image: ]
[bookmark: _Toc68769601][bookmark: _Toc68776123]Figure 13: ASPEN Case Comparison Save ASPEN Change File (*.CHF) Window
· All ASPEN users must follow the above mentioned steps and ensure proper file naming convention usage when they are creating their change file logs (*.TXT) and change files (*.CHF).
· These change file logs (*.TXT) and change files (*.CHF) created by the SPWG members need to be sent to ERCOT for further screening for possible discrepancies before running them during the next pass case build.
· All the change file logs (*.TXT) and change files (*.CHF) created by ERCOT, on behalf of the SPWG members who do not use ASPEN, will be sent to the SPWG members for their review. These logs will identify any errors during the change file creation process.
[bookmark: _Toc68776032]Current Year (CY) and Future Year (FY) ASPEN Base Case Building (ERCOT)
· CY (YYYY):
· Pass0:
· The CY case (YYYY) Pass0 is built by using the previous FY case (YYYY) PassFinal as base case and importing the incremental changes that took effect between that PassFinal and the beginning of the CY (YYYY) case build.
· Pass1 through PassFinal:
· The CY case (YYYY) Pass1 through PassFinal are built by importing the incremental changes that take effect between each pass (latest pass to the upcoming pass).
· FY (YYYY+1 through YYYY+5):
· YYYY+1:
· The FY case (YYYY+1) Pass0 is built by using the previous FY case (YYYY+1) PassFinal as base case and importing the incremental changes that took effect between the previous FY case (YYYY) PassFinal through the CY case (YYYY) PassFinal.
· YYYY+2:
· The FY case (YYYY+2) Pass0 is built by using the previous FY cas (YYYY+2) PassFinal as base case and importing the incremental changes that took effect between the previous FY case (YYYY+1) PassFinal through the current FY case (YYYY+1) Pass0.
· YYYY+3:
· The FY case (YYYY+3) Pass0 is built by using the previous FY case (YYYY+3) PassFinal as base case and importing the incremental changes that took effect between the previous FY case (YYYY+2) PassFinal through the current FY case (YYYY+2) Pass0.
· YYYY+4:
· The FY case (YYYY+4) Pass0 is built by using the previous FY case (YYYY+4) PassFinal as base case and importing the incremental changes that took effect between the previous FY case (YYYY+3) PassFinal through the current FY case (YYYY+3) Pass0.
· YYYY+5:
· The FY case (YYYY+5) Pass0 will be the same as the FY case (YYYY+4) Pass0.
· Pass1 through PassFinal:
· The FY cases (YYYY+1 through YYYY+5) Pass1 through PassFinal are built by importing the incremental changes that take effect between each pass (latest pass to the upcoming pass).

· All the future year cases are built from the final case of the future year case build as base case, and incremental change files are added to this base case to create future year cases.
· For example if we are in the year 2021, then ERCOT will use the 20_SPWG_2022_FY_FinalPass.dxt as base case and import the incremental change file to this case.
· The incremental change file for the year 2021 is created by using the ASPEN Case Comparison tool to compare the 20_SPWG_2021_FY_FinalPass.DXT selected as File “A”, and the 21_SPWG_2021_CY_FinalPass.DXT selected as File “B”. This change file (2021 changes .CHF) is then imported to the 20_SPWG_2022_FY_FinalPass.DXT to build the 21_SPWG_2022_FY_Pass0.DXT.

· Once ERCOT receives all the Change Files (*CHF) from ASPEN users and when ERCOT creates the remaining Change Files (*.CHF) for Non ASPEN users, the data is ready to build the new system protection base case. It is however, recommended that AEP & ONCOR’s Change File (*CHF) are executed last as they are some of the biggest networks in the ERCOT area with the greatest number of tie lines

· ERCOT will use last year’s case as defined previously to create this year’s system protection base case.

· For creating any subsequent base cases for Pass1 and beyond, ERCOT will use the previous pass base case as the starting point for building the next pass base case. The following table will give an example on what base case should be selected when creating a new base case for Pass3.
· After the base case is selected, open the base case in ASPEN OneLiner. After the case is opened, go to menu File > Read Change File… After you click on the “Read Change File…” link, ASPEN will prompt the user to select the Change File (*.CHF) which needs to be read. See screenshot for reference. 

[image: ]
[bookmark: _Toc68776124]Figure 14: OneLiner Open Change File (*.CHF) Window Screenshot

· After selecting the Change File (*.CHF) and clicking the “OK” button, ASPEN will prompt the user with a confirmation dialog which asks the user permission to apply that change to the base case. Select “Rest OK” button from the confirmation dialog so that ASPEN will incorporate all the changes from the Change File (*.CHF) to the base case. See screenshot for reference.
[image: ]
[bookmark: _Toc68776125]Figure 15: OneLiner Change File (*.CHF) Confirmation Dialog Screenshot
· After the previous step is performed, OneLiner will prompt with another Message Box where it lists any errors or warning and also tells the user to see TTY window for complete log. Once the user clicks the “OK” button, OneLiner will open the TTY log window. See screenshot for reference.

[image: ]
[bookmark: _Toc68776126]Figure 16: OneLiner Change File (*.CHF) Process Complete Window

· After all the change files have been read then the TTY log data needs to be copied to the clipboard by going to menu Edit > Copy Selected Text to Clipboard. Once the above task is performed, open Notepad and paste the data in Notepad and save the file with the file naming convention described in the previous section. For example if the base case that is being built is for 2021 CY case then the log file name should be as follows. SPWG_2021_CY_Change_File_Import_Log_Updated_02012021_Pass1.txt

· After all the Change Files (*.CHF) have been read, then save the case with a new case name which should follow the file naming convention described in the previous section. For example, if the base case that is being built is for 2021 CY Pass2 then the file should be saved with the following naming convention 21_SPWG_2021_CY_05212021_Pass2.olr

· Once the new case is created, then ERCOT members should export the data to PSS/E format. This is necessary as some members do not use ASPEN for building the base cases.

· To export the data in PSS/E format go to Menu File > Export > Network Data and ASPEN will prompt you with the Network Summary pop up window where the user needs to select the following options. Always check the Checkbox “Include tie lines” in the Export Network data Pop up window. See screenshot for reference. 
[image: ]
[bookmark: _Toc68776127]Figure 17: OneLiner Export Network Data Window
· After selecting the appropriate options from the Export Network Data Window, hit the “OK” button which will bring up the ASPEN to PSS/E Data Conversion pop up window where the user needs to select the appropriate PSS/E version and also can define where to start the fictitious bus numbers if there are no bus numbers defined in the network. The following options will be used by ERCOT when converting ASPEN file to PSS/E file. See screenshot for reference.
[image: ]
[bookmark: _Toc68776128]Figure 18: OneLiner ASPEN-to-PTI PSS/E Version Selection Window
· After the appropriate PSS/E version is selected and when the user hits the “OK” button then the program will prompt the user to define the Raw file name. The file naming convention defined in the previous section should be followed. For example if ERCOT is building the 2021 CY Pass 2 case then the Raw file name should be as follows 21_SPWG_2021_CY_05212021_Pass2.raw. 
· Once the user defines the raw file name and hits the “Save” button, the program will prompt the user to define the seq file name. The file naming convention defined in the previous section should be followed. For example if ERCOT is building the 2011 CY Pass 2 case then the seq file name should be as follows 21_SPWG_2021_CY_05212021_Pass2.seq.
· After the user defines the seq file name and hits the “Save” button, program will create the *.raw & *.seq files in the specified directory.
[bookmark: _Toc68776033]Fault Analysis Using ASPEN

· After exporting the *.raw and *.seq files return to ASPEN OneLiner to complete the Bus Fault Summary Analysis. To do this go to Menu > Faults > Bus Fault Summary. See screenshot for your reference. 

[image: ]
[bookmark: _Toc68776129]Figure 19: OneLiner Bus Fault Summary Window
· In the Bus Fault Summary window uncheck the “Exclude tap buses” option and select “OK” button then the program will prompt the user to define the csv file name. The file naming convention defined in the previous section should be followed with the addition of the report name appended to the end of the file name. For example if ERCOT is building the 2021 CY Pass 2 case then the csv file name should be as follows 21_SPWG_2021_CY_05212021_Pass2_Bus_Fault_Summary.csv.

· Currently there are over 12,000 buses in the SPWG case if the total bus count is off cancel the current run and start a new run double checking the “Exclude tab buses” option.
[image: ]
[bookmark: _Toc68776130]Figure 20: OneLine Bus Fault Summary Bus Count

· Current Year Passes: Fault data for the current year is compared to its own data generated as the future – year data in preceding year’s final future – year pass. For example, the Fault Data for the current year 2021 is compared to its own data, when generated as a future – year data in the final pass of 2020. See below for an example.
> 2021 CY Pass 1 data with 2021 FY Final Pass data (created in Year 2020)
> 2021 CY Pass 2 data with 2021 FY Final  Pass data (created in Year 2020)
> 2021 CY Pass 3 data with 2021 FY Final  Pass data (created in Year 2020)
> 2021 CY Pass 4 data with 2021 FY Final  Pass data (created in Year 2020)
> 2021 CY Pass5 FINAL data with 2021 FY Final  Pass data (created in Year 2020)
The comparison of the CY 2021 Pass 1, 2, 3, 4, and 5 with FY 2021 data enables us to observe data 
Progressions with each pass and look for any significant differences between respective passes.

· Future Year Passes: Fault data for the 1st future year is compared to the same year’s data as the FY data base in the preceding year. In other words, Fault data for the future year CY + 2 is compared to the Fault data for the future year CY + 1 and so on. Fault data of the year succeeding the current year is compared to its Fault data from the last pass. In other words, Fault data for the future year CY + 1 for the current pass Pass2 is compared to its fault data in the pass Pass1.
> Comparing 2021 CY (created this Year) with 2022 FY Pass 2 data (created in this Year)
> Comparing 2022 FY Pass 2 data with 2023 FY Pass 2 data
> Comparing 2023 FY Pass 2 data with 2024 FY Pass 2 data 
> Comparing 2024 FY Pass 2 data with 2025 FY Pass 2 data 
Note: We no longer calculate absolute differences between fault currents of two compared   
cases. The resultant +ve or -ve value of the difference indicates whether the current has
increased or decreased over the previous years data. 

· Once entered into the spreadsheets, the data for all the companies is merged and sorted by the Bus numbers in the ascending order.

· Data of a given bus, for all years stored in their respective columns should be aligned in same row.

· Use the appropriate formulae to calculate the difference in the three – phase and the single – phase fault currents, for a particular bus between two consecutive years and also the respective percentage changes in fault currents (Three – phase and Single phase) for a particular year over its preceding year 

· The fault spreadsheet is now complete and sent to SPWG members for review.
[bookmark: _Toc68776034]Final Output – Files Sent to TSPs for Review

· ASPEN Files
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN.OLR
· All TSP Submitted .CHF files and their respective import log.
· All TSP .CHF file converted from PSS/E .idv format

· PSS/E Files
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN.raw
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN.seq
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN.sav

· Excel Reports
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_Bus_Fault_Summary.csv
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_BusComparison.xlsx
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_Generation_Modeling.xlsx
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_nearest_generator_report.xlsx
· BB_SPWG_CCCC_XX_MMDDYYYY_PassN_TSP_Response.xlsx

[bookmark: _Toc68776035]Base Case Building Schedule
· The SPWG and ERCOT determine the CY and FY case building schedules on an annual basis.  The CY case is typically completed by end of March and the FY cases are typically completed by end of June.
[bookmark: _Toc68776036]Modeling Methodologies
[bookmark: _Toc68776037]Pre-fault Voltage
· When a linear network solution is used in ASPEN, the prefault bus voltages are calculated using a matrix form of Ohm’s law taking into account all network elements. ERCOT will use generator bus voltages and angles from SSWG summer case of relevant year to update the ref.V and ref.Ang fields in SPWG cases. For example to build 21_SPWG_2021_FY_05212021_Pass0.olr case, ERCOT shall obtain generator reference voltage and angle from the SSWG summer peak case of year 2021 built as part of SSWG case builds.
[bookmark: _Toc68776038]Generator Data – Translation of RARF Generator Data Parameters into ASPEN OneLiner

· The table below identifies the mapping of Resource Asset Registration Form (RARF) data parameters into ASPEN OneLiner Generating Unit Info parameters.  Saturated values for Impedances shall be entered into ASPEN OneLiner.  All values are on a per-unit basis on the MVA base provided for the unit. For Current limited generators such as wind turbines of types 3&4, use the Current limit values from RARF.

	RARF Generator Data Parameter
	Acronym
	ASPEN OneLiner Generating Unit Info

	MVA Base
	MVA base
	Unit rating (MVA)

	Saturated Subtransient Reactance
	X’’dv
	Subtransient (jX)

	Saturated Transient Reactance
	X’dv
	Transient (jX)

	Saturated Positive Sequence Z (Saturated Synchronous Reactance)
	Xdv
	Synchronous (jX)

	Saturated Negative Sequence Reactance
	X2v
	- sequence (jX)

	Saturated Zero Sequence Reactance
	X0v
	0 sequence (jX)

	Armature Positive Sequence Resistance
	R1
	Subtransient (R), Transient (R), Synchronous (R)

	Armature Negative Sequence Resistance
	R2
	- sequence (R)

	Armature Zero Sequence Resistance
	R0
	0 sequence (R)

	Instantaneous Controlled Fault Current Magnitude (Multiple of full load current) for Turbine Types 3 & 4
	A
	Current Limit A

	Controlled Fault Current Magnitude At 4 plus cycles after fault (Multiple of full load current) for Turbine Types 3 & 4
	B
	Current Limit B


Table 3: Translation of RARF Generator Data Parameters

[image: ]
[bookmark: _Toc68776131]Figure 21: Sample Translation of Generator Data Sheet to ASPEN Generating Unit Info
[bookmark: _Toc68776039]Model Wind and Solar Plants in ASPEN OneLiner

· Wind turbine and solar plants are connected to the grid through inverters that dictate the characteristic response during short-circuit fault scenarios. For this reason, they do not act like synchronous or asynchronous machines. Ideally, these sources should be modeled as a current source that mimics the controller characteristics of the inverters.

· The present methodology in ASPEN Oneliner recommends modeling WTG and PVG using a current-limited generator model. Alternately, Type-4 WTG and PVG may be modeled as Voltage Controlled Current Sources (VCCS). This method is being further developed for the next ASPEN software release. ASPEN Oneliner V15 will include a new generator model for Type-4 WTG and PVG.

[bookmark: _Toc68776040]Current Limited Generators
· ERCOT models renewable generation with a current limited generator model. Because of the characteristics of these generators, certain modifications are necessary to obtain a suitable approximation. ASPEN provides guidelines for modifying current limited generator models for wind and solar applications.

· Type-4 wind turbines and solar plants behave in a similar fashion, and are governed entirely by their power electronics and control algorithm. The machines are ungrounded and therefore contribute no zero sequence current. During a fault condition, these machines will initially rise to about 2.5 times full-load current. Within a few cycles, the current will usually settle to 1.1 or 1.2 times full-load current. There will be slight variations between manufacturers and their specific control schemes. Figure 24 shows a typical model for a Type-4 WTG or PVG. The zero sequence impedance is set to j999 pu to prevent zero sequence current. Positive sequence impedance is set to j0.02 pu (not the impedance of the generator). ASPEN also recommends setting the negative sequence impedance to j999 in most cases, as the machines’ controlled response is to limit the flow of negative sequence current. There has been disagreement over the values to use for negative sequence impedance due to its impact on terminal voltage during a fault.

· Type-3 wind turbines are doubly-fed machines, which is a hybrid between a synchronous and induction machine. The behavior of these turbines is therefore more complex. During a close-in fault, high rotor currents cause the machines to “crowbar” to prevent damage to the power electronics. At this point the turbines will act like an induction machine. When the crowbar is not in use, Type-3 turbines will behave similar to Type-4 turbines. Protection studies will need to consider Type-3 turbines with and without current limits to account for both potential scenarios. Figure 25 shows a typical model for a Type-3 WTG. Like Type-4 machines, ASPEN recommends settings Zo to j999. The positive sequence impedance should be set to the transient or sub-transient impedance of the generator. 

[image: ]
[bookmark: _Toc68776132]Figure 22: Current Limited Generator for Type-4 WTG and PVG

[image: ][image: ]
[bookmark: _Toc68776133]Figure 23: Current Limited Generator for Type 3 WTG

[bookmark: _Toc68776041]Current Limited Generator Limitations and Protection Considerations
· The current limited generator model has limited ability to predict post-fault voltages near the generator terminal. This voltage can also be abnormally high when setting negative sequence impedance to j999.

· It is important to have a Y-D-Y high-side MPT modeled from test report data, as this will be the only contribution for ground faults.

· For Type-4 WTG and PVG, current limit B may be more useful for most protection studies, as the instantaneous fault current will typically settle within a few cycles.

· For close-in faults involving Type-3 WTG, it may be desirable to utilize current limit A, or set this current limit to zero to disable it. This will be useful for the crowbar condition. Otherwise, current limit B can be used.


[bookmark: _Toc68776042]Transmission Line or Branch Data
· Transmission line/branch data shall be calculated based on TSP’s criteria and entered as per unit values on the nominal kV base. 

· Positive Sequence Data - Positive sequence parameters shall include the impedance and include shunt susceptance where applicable.

· [bookmark: _Toc521570611]Negative Sequence Data - Negative sequence parameters shall be assumed to be equal to their positive sequence counterparts.  These values are not explicitly entered into the short circuit case.   
     
· [bookmark: _Toc521570612]Zero Sequence Data - Zero sequence parameters shall include the impedance and include shunt susceptance where applicable.


[image: ]
[bookmark: _Toc68776134]Figure 24: Example of Line Data Entry

[bookmark: _Toc68776043]Mutual Impedance Modeling Guidelines

· The impact of mutual impedance on ground fault relaying performance and fault location can be significant and therefore should be included within the short circuit base cases. Absent specific company policies in this area, suggested guidelines for the modeling of mutual impedance effects by ERCOT TSPs are as follows:

· Mutual impedances should be included for circuits sharing a common structure and if the coupled length of adjacent circuits exceeds 10% of the shortest line circuit or if the mutual impedance exceeds 10% of the smallest circuit zero sequence impedance.

· Mutual impedances should be included for circuits sharing a common ROW less than 100 feet wide and if the coupled length of adjacent circuits exceeds 10% of the shortest line circuit or if the mutual impedance exceeds 10% of the smallest circuit zero sequence impedance.


· TSPs may opt to model the mutual impedance of certain circuits in greater detail as warranted.

· In the case of mutual impedances between two circuits owned/operated by different TSPs, the two TSPs shall come to an agreement on which entity shall submit the mutual impedance (“Mutual Pair” in ASPEN OneLiner) information during the annual case building process.  The TSP submitting the data shall be documented in the “Memo” field in ASPEN OneLiner, as shown below.

[image: mutual pair]
[bookmark: _Toc68776135]Figure 25: Sample Mutual Pair Data

[bookmark: _Toc68776044]Coordination of Tie Lines
· A tie line is defined as any transmission circuit with multiple owners represented within the context of the transmission circuit’s associated facility.  Careful coordination and discussion is required among SPWG members to verify the inclusion and accuracy of all modeled tie line data.  Even in situations where no new tie lines are added to a network model, there could be many tie line changes.  Construction timing for future points of interconnection or modified existing points of interconnection can also change and must be monitored.

· It is imperative for neighboring entities to coordinate tie data in order to allow CY and FY work activities to proceed unimpeded. Coordination of tie line data includes timely agreement between entities on the following parameters for each tie line:
· In-service/ out-service dates for ties
· From bus number
· To bus number
· Circuit identifier
· Impedance
· Mutual Impedance
· Transformer adjustment (LTC) data
· Status of branch
· Circuit miles
· Ownership (up to four owners)
· Entity responsible for submitting data  

[bookmark: _Toc68776045]Transformer Data

[bookmark: _Toc68776046]Generator Step-up Transformers
· Wind and solar pad-mount transformers impedances will be in per unit on the transformer’s own base and the tapped value of the voltage.

· Additional modeling guidelines shall be provided as part of a future manual revision. Refer to Appendix A for more information.

[bookmark: _Toc68776047]Transmission Auto Transformer
· Transformer data shall be obtained from test reports provided by the manufacturer.  If there is no test report for a particular transformer, as can be the case for older legacy units, the TSP must be able to provide the rationale used for determining the parameter values.

· All existing windings of transformers shall be modeled.   A three winding transformer, for example, shall have all of its windings explicitly modeled regardless of whether any winding lacks a load, such as may be the case with a tertiary winding.  

· All impedances may be in per unit on the system MVA base and the tapped value of the voltage.

Impedance Data
· [bookmark: _Toc521570619]Positive Sequence Data - Positive sequence values should include both the copper losses and leakage reactances for all windings.

· [bookmark: _Toc521570620]Negative Sequence Data - Negative sequence parameters should be assumed to be equal their positive sequence counterparts. These values are not explicitly entered into the short circuit case.

· [bookmark: _Toc521570621]Zero Sequence Data - Accurate zero sequence data is vital for the proper calculation of current magnitudes for any fault involving a path to ground.  This is the case for all windings (including buried tertiary windings) regardless of whether they are connected to a load. Zero sequence values should include both the resistances and reactances for all windings.


[image: ]From Test Report or RARF
The per unit impedances are based on the tap value
Ensure proper base
Ensure proper configuration
Information only.  Does not affect calculations

[bookmark: _Toc68776136]Figure 26: Example of 2 Winding Data Entry

· 2 Winding Data Entry Guidelines
· MVA1, MVA2, and MVA3 have no effect on any calculations
· MVA base is changeable. 100 MVA is preferred.  Bear in mind that an external case may be using a different value.
· R, X, Ro, and Xo information comes from test report data.
· B and Bo are the magnetizing susceptances.  Rarely used in short circuit calculations.  B can be determined from test report no load data.
· Zg1 is used only if external grounding impedance exists
· The tap values entered should match the voltage from which the transformer impedances are determined.  The bus nominal value, the in-service tap, and the test report tap may not be the same.
· G1, B1, G10, B10, G2, B2, G20, and B20 are shunt admittances and not recommended to be used by ASPEN.
· Use the proper lead or lag configuration for a delta winding.
· “Metered at” is not used (Power Flow Only)
· LTC is not used (Power Flow Only)


[image: ] The per unit impedances are based on the tap value
From Test Report or RARF
Ensure proper base
Ensure proper Δ winding configuration

[bookmark: _Toc68776137]Figure 27: Example of 3 Winding Data Entry

· 3 Winding Data Entry Guidelines
· MVA1, MVA2, and MVA3 have no effect on any calculations
· MVA base is changeable. 100 MVA is preferred.  Bear in mind that an external case may be using a different value.
· Zps, Zpt, Zst, Zps0, Zpt0, and Zst0 information comes from test report data.
· B and Bo are the magnetizing susceptances.  Rarely used in short circuit calculations.  B can be determined from test report no load data.
· Zg1, Zg2, and Zgn are used only if external grounding impedance exists
· The tap values entered should match the voltage from which the transformer impedances are determined.  The bus nominal value, the in-service tap, and the test report tap may not be the same.
· Use the proper lead or lag configuration for a delta winding.
· “Metered at” is not used (Power Flow Only)
· LTC is not used (Power Flow Only)

Note:  All transformer data should be provided by the applicable functional entity as per NERC MOD-32-1 Attachment 1 (“Data Reporting Requirements’)

[bookmark: _Toc68776048]Appendix A: Wind & Solar Aggregation Techniques

A wind or solar generation plant can be aggregated from a detailed ASPEN model or from the RARF form. Calculations will need to be performed for the padmount transformers and generating units.
· Padmount transformers can be aggregated based on the complex impedance and number of transformers using the following equation:

*

Where Z_xfmr is the complex padmount impedance, N is the number of turbines, and MVA_base-xfmr is the power base used for the transformer impedance. MVA_base-new is typically calculated by multiplying the transformer MVA base by the number of transformers, or can be set to 100MVA.  
[bookmark: _GoBack]If a detailed ASPEN model is provided by the generator, it is important to verify the information against the RARF, as they should be congruent. Examples are shown in Figure 30 and Figure 31.
[image: ]
[bookmark: _Toc68776138]Figure 28: Padmount Transformer ASPEN Model Data

Using the impedances shown above, aggregate impedance values for 60 turbines/transformers would be calculated as:







Note that by using a 225 MVA base the impedance equation reduces, leaving the aggregate impedances the same as for a single transformer.

[image: ]


· Generating units can be aggregated from the RARF or a detailed ASPEN model. Generator impedances will be in per-unit at the unit MVA, and will not change for aggregate generators. The “Unit rating MVA” in ASPEN will simply be the unit MVA multiplied by the number of units. MW, MVAR, Pmax, Pmin, Qmax, and Qmin can be calculated the same way, if they are used. These values are not necessary for short circuit modeling calculations, but can be useful if the same model is to be used for PSSE. 
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