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1. Introduction

1.1. ERCOT System Protection Working Group Scope

· The ERCOT System Protection Working Group (SPWG) operates under the direction of the Reliability and Operations Subcommittee (ROS). The SPWG is a non-voting working group whose members include representatives from ERCOT Transmission Service Providers (TSPs) and ERCOT staff.  SPWG responsibilities related to case building are further described as follows:

· Develop and maintain short circuit base case for the current year.  The case, collectively known as Current Year (CY) base case, is produced by the SPWG by approximately April 1st on an annual basis.

· Develop and maintain short circuit base case for the future years. The cases, collectively known as Future Year (FY) base cases, are produced by the SPWG by approximately July 1st on an annual basis.
· Review and update, as necessary (at least every five years), the SPWG Procedural Manual to reflect current planning practices and the latest short circuit base case modeling methodologies.

1.2. Introduction to Short Circuit Case Building Procedures and Methodologies  

· The principal function of the SPWG is to provide ERCOT system current year and future year short circuit models, or base cases, which contain appropriate equipment characteristics, system data, and shall represent projected system conditions.  This procedure manual is intended to demonstrate compliance with NERC Reliability Standards applicable to short circuit modeling. 

· Short Circuit models are bus-branch representations of the high voltage transmission system (60 kV and above), which includes buses, branches, impedances, reactive devices, transformers, generators, and DC lines. 

· The ROS directs the SPWG as to which base cases are to be created.  Currently, the SPWG builds CY and FY base cases on an annual basis.

2. System Protection Base Case Building
2.1. Overview
· ASPEN OneLiner has been chosen by System Protection Working Group (SPWG) as the software package for building the ERCOT system current year and future year short circuit base cases. Previously, SPWG used PSS/E to build all the short circuit base cases which will be discontinued starting with the 2011 current year short circuit base case building.
· Before starting the case building process, ERCOT & SPWG members are required to be using the same ASPEN & PSS/E versions. SPWG shall decide at the November SPWG Meeting which ASPEN & PSS/E version will be used for the next year case building process.
· Short circuit base cases are created in two categories:
· Current Year (CY)

· Future Years (FY): Five years following the current year i.e. CY+1, CY+2, CY+3, CY+4, and CY+5
· Example: For the calendar year 2016, the following short circuit cases will be created, namely: 2018 CY case, 2019 FY, 2020 FY, 2021 FY, 2022 FY, & 2023 FY cases.
· Members short circuit base case data shall be submitted reflecting the following conditions:
· All equipment expected to be in-service by June 30th of the case year shall be included in the case.
· All generator units that meet the requirements of ERCOT Planning Guide Section 6 shall be modeled in the appropriate case..
· Mutual impedance effects should be included.  For more details, refer to section 1.9.
· The system base shall be 100 MVA.

· For those members who don’t have/use ASPEN, they may submit the files in PSS/E. No other format is acceptable.

· For the 2016 case building process, SPWG has agreed to use ASPEN v14.5 and PSS/E v33. If SPWG members do not have the appropriate versions installed on their systems, then they will need to upgrade to the acceptable versions as determined by SPWG for building the short circuit cases.

· All the ASPEN and PSS/E files which are submitted to ERCOT should be compatible with the above agreed versions.
2.2. File Naming Convention
· The following file naming convention shall be followed by SPWG members & ERCOT members when submitting the files to ERCOT. No other file naming convention is allowed.
· ASPEN File Naming Convention

· General File Naming Convention: CompanyAcronym_YYYY_CY/FY_PassX

· Example: If AEP is submitting their 2012 FY Pass2 case changes to ERCOT then the File Name shall be as follows AEP_2012_FY_Pass2
· PSS/E File Naming Convention
· General File Naming Convention: CompanyAcronym_YYYY_CY/FY_PassX

· Example: If CNP is submitting their 2013 FY Pass3 case changes to ERCOT then the File Name should be as follows CNP_2013_FY_Pass3
· For members submitting the data in PSS/E format, the RAW file should have a “.raw” extension and the SEQ file should have a “.seq” extension.  Members need to send in “re-change” raw files to prevent ERCOT from having to manually adjust member-submitted files.
· ERCOT Log File Naming Convention for converting PSSE to ASPEN
· General File Naming Convention: CompanyAcronym_YYYY_CY/FY_Conversion_From_PSSE_to_ASPEN_PassX.REP
· Example: If ERCOT is converting AEN 2012 FY Pass2 PSSE raw and seq case changes, then the File Name should be as follows AEN_2012_FY_Conversion_From_PSSE_to_ASPEN_Pass2.REP
· ERCOT Change File Creation Log Naming Convention
· General File Naming Convention: CompanyAcronym_YYYY_CY/FY_Change_File_Log_PassX.TXT
· Example: If  ERCOT is converting AEN 2012 FY Pass2 DXT file to a ASPEN change file, then the Log File Name should be as follows AEN_2012_FY_Change_File_Log_Pass2.TXT
· ERCOT Change File Import Log Naming Convention 
· General File Naming Convention: SPWG_YYYY_CY/FY_Change_File_Import_Log_Updated_MMDDYYYY_PassX.TXT
· Example: If ERCOT is compiling the 2012 FY Pass2 case from the changes received from TSPs then the case build Name should be as follows SPWG_2012_FY_Change_File_Import_Log Updated_05102011_Pass2.TXT
· ERCOT Build Case File Naming Convention 
· General File Naming Convention: SPWG_YYYY_CY/FY_Updated_MMDDYYYY_PassX.DXT
· Example: If ERCOT is compiling the 2012 FY Pass2 case from the changes received from TSPs then the case build Name should be as follows SPWG_2012_FY_Updated_05102011_Pass2.DXT
· The Updated date in the above file name is the date on which ERCOT compiles all the changes received from TSPs.
2.3. Converting PSSE Files to ASPEN *.DXT Format
· For members who don’t have/use ASPEN, ERCOT has agreed to accept PSS/E files from those companies. 
· As mentioned in the above section, any PSS/E files submitted to ERCOT should follow the file naming convention and also should be in the same PSS/E version as described before. If members do not submit in the correct PSS/E version, then when converting from PSS/E to ASPEN the data may not be converted correctly.

· PSS/E “.raw” files should be created using the “Configure RAW file to” option “Use with RDCH”.
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Figure 1a: PTI PSS/E-ASPEN Conversion RAW data Save Network Data Screenshot
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Figure 1b: PTI PSS/E-ASPEN Conversion Sequence Data Save Network Data Screenshot
· Once ERCOT receives the PSS/E files, then ERCOT will use the PTI PSS/E-ASPEN conversion utility program provided by ASPEN to convert PSS/E files to ASPEN *.DXT format.
· The PTI PSS/E-ASPEN conversion program can be accessed through Program Files > ASPEN OneLiner > PTI PSS/E-ASPEN

· After you open the PTI PSS/E-ASPEN conversion program, go to File > Convert. Once you click on the Convert link, it will open a popup window where you can select the raw file which needs to be converted. The following screenshot shown below is for reference.
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Figure 2: PTI PSS/E-ASPEN Conversion Raw File Selection Screenshot
· After an appropriate *.raw file is selected for conversion, the conversion utility program will ask to confirm the PSS/E version along with another option, where you can select if you need to read the *.seq file also. For converting PSS/E to ASPEN format, both the*.raw & *.seq files must be read. See the screenshot for reference.
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Figure 3: PTI PSS/E-ASPEN Conversion File Options Screenshot
· Once the option to read *.seq file is selected, conversion program will provide you with another popup window where the user can select the appropriate *.seq file. See the screenshot for reference.
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Figure 4: PTI PSS/E-ASPEN Conversion Seq File Selection Screenshot
· After the appropriate *.seq file is selected for conversion, the ASPEN conversion program will prompt the user with a save window where you need to enter the file name by following the file naming conventions which are described in previous section. See the screenshot for your reference.
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Figure 5: PTI PSS/E-ASPEN Conversion Save Converted File Screenshot
· After the user enters the file name and clicks the “Save” button then the ASPEN PTI PSS/E-ASPEN conversion program will prompt the user with the conversion options. The following screen shot will show what options and check boxes ERCOT will be using when converting the PSS/E files to ASPEN *.DXT format. Any ERCOT personnel who is building the short circuit case and who would like to convert PSS/E files to ASPEN *.DXT format should use the following options as shown in the screenshot below.
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Figure 6a: PTI PSS/E-ASPEN Conversion Options Screenshot
· Once, the user selects the appropriate options as shown above and clicks the “OK” button, ASPEN conversion program will convert the *.raw & *.seq files to ASPEN *.DXT format. When the conversion is done, it creates a conversion log which needs to be saved by following the log file naming conventions which was described in previous section. To save the log file to a text file first select all the data in the window by going to Menu and View > Select All. After the user selected all the data then go to menu View > Save Selected Text to File and the conversion program will prompt the user to enter the file name to which the conversion logs will be saved. 
· All the conversion logs should be sent to SPWG members when sending the cases out for their review. These logs will inform the members if any errors are encountered during the conversion process so that the data can be corrected and resubmitted during the next pass.

2.4. Creating ASPEN Change File (*.CHF)
· When submitting data to ERCOT, SPWG members who use ASPEN for building short circuit cases need to submit the ASPEN Change File (*.CHF) to ERCOT and for members who use PSS/E to build the short circuit cases, ERCOT will create the change files (*.CHF) on their behalf before compiling the case in ASPEN OneLiner. Which is created based upon a base case which ERCOT sends to the members before a case is built. This case should only be used when creating the Change File (*.CHF) for Pass0 submissions. All the other change files must be created based upon the previous pass case. For example, if a user is creating a change file for Pass2 then the base case that should be used is the Pass1 case.
· For creating Pass0 Change files in ASPEN, members should use the base case which is sent by ERCOT during the initial case building process. For example if we are building the 2011 CY case, then the change file should be made by using SPWG_2011_FY_Updated_10162010_Pass4.dxt which was created during the prior year.

· When building the Future Year (FY) cases, for Pass0 ERCOT shall use the final case of the current year case build as base case and add change files as described in the graphic below. So for the year 2014, ERCOT shall use the SPWG_2014_CY_Updated_03252014_Final.dxt as base case and add change files to this case.

[image: image9]
Figure 6b: Change Files Used for Creating FY Pass0 Cases
· To create the incremental change file for the year 2015, i.e. the 2015 CHF (ASPEN change file) is created by comparing the cases SPWG_2014_FY_Updated_07112013_Pass4.DXT and SPWG_2015_FY_Updated_07112013_Pass4.DXT both built last year, and this 2015 CHF file is added to the base case SPWG_2014_CY_Updated_03282014_Final.DXT to build SPWG_2015_FY_Updated_ 04112014_Pass0.dxt.
	Change File for Creating Pass0
	Base Case to be Used for Creating Change File (*.CHF)
	When the Base Case is Created

	2014_CY
	SPWG_2014_FY_Updated_07112013_Pass4.DXT
	Last Year

	2015_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2016_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2017_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2018_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2019_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year


Table 1: Base Case Selection for Creating Pass0 ASPEN Change Files (*.CHF)
· For creating any subsequent change files for Pass1 and beyond, members should use the previous pass case as the base case for creating the change file (*.CHF). The following table will give an example on what base case should be selected when creating a change file (*.CHF) file for Pass3.
	Change Files for Creating Pass3
	Base Case to be Used for Creating Change File (*.CHF)
	When the Base Case is Created

	2011_CY
	SPWG_2011_CY_Updated_03152011_Pass2.DXT
	This Year Pass2

	2012_FY
	SPWG_2012_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2013_FY
	SPWG_2013_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2014_FY
	SPWG_2014_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2015_FY
	SPWG_2015_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2016_FY
	SPWG_2016_FY_Updated_05202011_Pass2.DXT
	This Year Pass2


Table 2: Base Case Selection for Creating Pass1 & Beyond ASPEN Change Files (*.CHF)
· When creating the change files, the naming convention defined in the previous sections should be followed. For example if AEP is creating a change file for Pass2 then the file naming conventions should be as follows AEP_2012_FY_Pass2.CHF
· ASPEN Change File (*.CHF) conversion program is located under Program Files > ASPEN OneLiner > Case Comparison. Once you open the Case Comparison program go to File > Open. ASPEN will prompt you with a popup window to select the Base Case File which is either *.DXT or *.OLR file. See the screenshot for your reference.
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Figure 7: ASPEN Case Comparison Open File A Popup Window Screenshot
· Once the base case is selected, ASPEN will prompt to select the updated case file which is file B so that it can create a Change File (*.CHF). Note the following relationship: Base Case + Change File = Updated Case. See the screenshot for your reference.
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Figure 8: ASPEN Case Comparison Open File B Popup Window Screenshot
· Once the updated case file is selected, the ASPEN case comparison program will give you another popup window where the following options must be selected before creating the Change File (*.CHF). Always create the change file by comparing “Bus Number” as Bus Numbers are unique in the ERCOT system and bus names may not be unique.
· Create the Change file just for your “Area” by selecting the “Inside” Radio Button and populating the required areas for which the change file needs to be created.  Effective beginning with the 2013 short circuit case building process, please note that generator facilities interconnected to a given TSP will have a +900 area number offset from the area of the TSPs interconnection facilities (e.g. area 907 vs. area 7) and those generator facilities should not be included in the change file.
· Also, before finalizing the options make sure you check the “Include ties between selected items and the rest of the network” checkbox as we would like to include the ties in the change file that is being created.

· The following are the options which needs to be selected when creating any Change File (*.CHF) either by SPWG members or by ERCOT. See the screenshot for your reference.
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Figure 9: ASPEN Case Comparison Options Selection Window Screenshot
· Once, the user selects the appropriate options as shown above and hits the “OK” button, ASPEN comparison program will prompt the user to define a file name for the Change File (*.CHF) log file. The log file naming convention should be followed as mentioned in the previous sections. For example if ERCOT is creating a Change File (*.CHF) for 2011 FY Pass0 case then the Change File (*.CHF) log file name should be AEN_2011_FY_Change_File_Log_Pass0.TXT. This section is only applicable to ERCOT who will be creating the Change File (*.CHF) for non ASPEN users. See the screenshot for your reference.
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Figure 10: ASPEN Case Comparison Save Difference Report Window Screenshot
· After the user defines the Change File (*.CHF) log file name, ASPEN Comparison program will prompt the user with another popup window where the user needs to select the destination and enter the file name for the Change File (*.CHF) which is been created by the program. Again, the file naming convention described in the previous section should be followed. For Example if a LCRA is creating a Change File (*.CHF) for 2011 FY Pass0 case, then the file name should be as follows LCRA_2011_Fy_Pass0.CHF. See the screenshot for reference.
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Figure 11: ASPEN Case Comparison Save ASPEN Change File Window Screenshot
· All the Change File (*.CHF) logs which are created by ERCOT on behalf of the SPWG members who do not use ASPEN, will be sent to the SPWG members for their review. These logs will identify any errors during the Change File (*.CHF) creation process.
· Once the Change File (*.CHF) has been created by members, then they need to send only the Change File (*.CHF) to ERCOT so that ERCOT can run that Change File (*.CHF) during the next pass case build procedure.

· Again, all ASPEN users need to follow the above mentioned options and also need to follow the File Naming convention when they are creating the Change File (*.CHF).
2.5. Building Base Cases Using ASPEN – ERCOT Process
· When building the base cases using ASPEN, the current year case is built from previous year case and this new case will have incremental changes after the previous year case has been finalized.

·  All the future year cases are built from the final case of the current year case build as base case and incremental change files are added to this base case to create future year cases. For example if we are in the year 2014, then ERCOT shall use the SPWG_2014_CY_Updated_03252014_Final.dxt as base case and add change files to this case.
· To create the incremental change file for the year 2015, i.e. 2015 CHF (ASPEN change file) is created by comparing the cases SPWG_2014_FY_Updated_07112013_Pass4.DXT and SPWG_2015_FY_Updated_07112013_Pass4.DXT both built last year, and this 2015 CHF file is added to the base case SPWG_2014_CY_Updated_03282014_Final.DXT to build SPWG_2015_FY_Updated_ 04112014_Pass0.dxt

· Once ERCOT receives all the Change Files (*CHF) from ASPEN users and when ERCOT creates the remaining Change Files (*.CHF) for Non ASPEN users, the data is ready to build the new system protection base case. It is however, recommended that AEP & ONCOR’s Change File (*CHF) are executed last as they are some of the biggest networks in the ERCOT area with the greatest number of tie lines.
· ERCOT will use last year’s case as defined previously to create this year’s system protection base case. Refer to Table 3 for details:
	Change File for Creating Pass0
	Base Case to be Used for Creating Change File (*.CHF)
	When the Base Case is Created

	2014_CY
	SPWG_2014_FY_Updated_07112013_Pass4.DXT
	Last Year

	2015_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2016_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2017_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2018_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year

	2019_FY
	SPWG_2014_CY_Updated_03282014_Final.DXT
	This Year


Table 3: Base Case Selection for Creating This Year’s Base Case
· For creating any subsequent base cases for Pass1 and beyond, ERCOT will use the previous pass base case as the starting point for building the next pass base case. The following table will give an example on what base case should be selected when creating a new base case for Pass3.

	This Year’s Base Case Pass3
	Base Case to be Used for Creating the New Base Case
	When the Base Case was Created

	2011_CY
	SPWG_2011_CY_Updated_03152011_Pass2.DXT
	This Year Pass2

	2012_FY
	SPWG_2012_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2013_FY
	SPWG_2013_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2014_FY
	SPWG_2014_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2015_FY
	SPWG_2015_FY_Updated_05202011_Pass2.DXT
	This Year Pass2

	2016_FY
	SPWG_2016_FY_Updated_05202011_Pass2.DXT
	This Year Pass2


Table 4: Base Case Selection for Creating This Year’s Pass1 & Beyond Base Case
· After the base case is selected, open the base case in ASPEN OneLiner. After the case is opened, go to menu File > Read Change File… After you click on the “Read Change File…” link, ASPEN will prompt the user to select the Change File (*.CHF) which needs to be read. See screenshot for reference.
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Figure 12: OneLiner Open Change File (*.CHF) Window Screenshot
· After selecting the Change File (*.CHF) and clicking the “OK” button, ASPEN will prompt the user with a confirmation dialog which asks the user permission to apply that change to the base case. Select “Rest OK” button from the confirmation dialog so that ASPEN will incorporate all the changes from the Change File (*.CHF) to the base case. See screenshot for reference.
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Figure 13: OneLiner Change File (*.CHF) Confirmation Dialog Screenshot
· After the previous step is performed, OneLiner will prompt with another Message Box where it lists any errors or warning and also tells the user to see TTY window for complete log. Once the user clicks the “OK” button, OneLiner will open the TTY log window. See screenshot for reference.
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Figure 14: OneLiner Change File (*.CHF) Process Complete Window
·  After all the change files have been read then the TTY log data needs to be copied to the clipboard by going to menu Edit > Copy Selected Text to Clipboard. Once the above task is performed, open Notepad and paste the data in Notepad and save the file with the file naming convention described in the previous section. For example if the base case that is being built is for 2011 CY case then the log file name should be as follows.

SPWG_2011_CY_Change_File_Import_Log_Updated_02012011_Pass1.txt

· After all the Change Files (*.CHF) have been read, then save the case with a new case name which should follow the file naming convention described in the previous section. For example, if the base case that is being built is for 2011 CY Pass2 then the file should be saved with the following naming convention SPWG_2011_CY_Updated_03152011_Pass2.DXT and SPWG_2011_CY_Updated_03152011_Pass2.olr
· Both the *.DXT and *.olr files need to be sent to SPWG for review.

· Once the new case is created, then ERCOT members should export the data to PSS/E format. This is necessary as some members do not use ASPEN for building the base cases.

· To export the data in PSS/E format go to Menu File > Export > Network Data and ASPEN will prompt you with the Network Summary pop up window where the user needs to select the following options. Always check the Checkbox “Include tie lines” in the Export Network data Pop up window. See screenshot for reference.
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Figure 15: OneLiner Export Network Data Window
· After selecting the appropriate options from the Export Network Data Window, hit the “OK” button which will bring up the ASPEN to PSS/E Data Conversion pop up window where the user needs to select the appropriate PSS/E version and also can define where to start the fictitious bus numbers if there are no bus numbers defined in the network. The following options will be used by ERCOT when converting ASPEN file to PSS/E file. See screenshot for reference.
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Figure 16: OneLiner ASPEN-to-PTI PSS/E Version Selection Window
· After the appropriate PSS/E version is selected and when the user hits the “OK” button then the program will prompt the user to define the Raw file name. The file naming convention defined in the previous section should be followed. For example if ERCOT is building the 2011 CY Pass 2 case then the Raw file name should be as follows SPWG_2011_CY_Updated_03102011_Pass2.raw. See screenshot for reference.
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Figure 17: OneLiner Save to PTI Raw Data File Window
· Once the user defines the raw file name and hits the “Save” button, the program will prompt the user to define the seq file name. The file naming convention defined in the previous section should be followed. For example if ERCOT is building the 2011 CY Pass 2 case then the seq file name should be as follows SPWG_2011_CY_Updated_03102011_Pass2.seq. See screenshot for reference.
[image: image21.png][Save to PTI Sequence Data Fi o5 2] x|

Savein: [ SPWG_2011_FY_Pass R =

File pame: [5PWEL2010_CY_Updated_03172010_Passtd.seq =l Save
B Carcel
T ew |

Savesstps  [Seares daafe (560)





Figure 18: OneLiner Save to PTI Seq Data File Window
· After the user defines the seq file name and hits the “Save” button, program will create the *.raw & *.seq files in the specified directory.
2.6. Fault Analysis Using PSS/E
· After exporting the *.raw & *.seq files from ASPEN OneLiner fault analysis needs to be performed on the cases. Before reading the *.raw file to PSS/E , open the *.raw file in notepad and make sure that the top three lines of the raw file reads as follows.

Example:
0,   100.00

ERCOT SYSTEM PROTECTION WG - ERCOT PSS/E VERSION 30.3.4

2011 CURRENT YEAR CASE - PASS 2 MODIFIED MM/DD/YYYY

· After first 3 lines reflect what was mentioned above then save the *.raw file and open the *.raw & *.seq files in PSS/E and save it as *.sav case. 

· Perform TREE - – Click on the command line input (CLI) icon on PSSE which opens the command line input terminal window. Before performing TREE make sure that Zero Impedance Line Threshold (THRSHZ) is 0.0001. To do this go to Menu>Power Flow>Solution>Parameters. See screenshot for your reference.
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Figure 19: PSS/E Solution Parameters Window
· Make sure that in Command Line Input (CLI) window, “Command Language” drop down menu, PSS/E response is selected. After that type TREE in the terminal window. Once you Type TREE and press enter it checks for Buses that are not in swing bus tree and checks for any islands. Now at this point all the islands needs to be disconnected by entering “1” in the CLI screen and press enter. Follow this until all the islands are disconnected. Once all the islands are disconnected CLI terminal will say “NO MORE ISLANDS”. At this point perform OUTS, ALL command which saves all the islands you just disconnected to a file. And you need to name the new file in the following format. SPWG_YYYY_CY/FY_Islands_Updated_MMDDYYYY_PassX.dat (X denotes the pass number). When OUTS, ALL command is executed, PSS/E will ask for OUTPUT DEVICE CODE, for which enter “2” which outs to a file. When you type in “2” and press enter then it will ask to input the file name which should be in SPWG_YYYY_CY/FY_Islands_Updated_MMDDYYYY_PassX.dat (X denotes the pass number) format. Once Command Line Interface (CLI) terminal displays “OUTPUT COMPLETED” close the CLI terminal window and save the case. See screenshot of CLI terminal window for reference.
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Figure 20: PSS/E Command Line Input (CLI) Window
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Figure 21: PSS/E Command Line Input (CLI) Window with Commands
· Perform FLAT, CL (classical flat start) Click on the command line input (CLI) icon on PSS/E which opens the command line input terminal window. Type FLAT, CL in CLI terminal window and press enter key. After pressing enter key it will give the following option “ENTER 1 TO SET TAP RATIOS TO UNITY:” Enter 1 and press enter key. Then PSS/E will give the following option “ENTER 1 TO SET CHARGING TO ZERO:” Enter 1 and press enter key. Then PSS/E will give the following option
“ENTER 1 TO SET BUS SHUNTS TO ZERO IN POSITIVE SEQUENCE

    

     2 TO SET BUS SHUNTS TO ZERO IN ALL SEQUENCES:”
Enter 2 and press enter key.

Then PSS/E will give the following option
“ENTER 1 TO SET SWITCHED SHUNTS TO ZERO IN ALL SEQUENCES:”
Enter 1 and press enter key.

Then PSS/E will give the following option
“ENTER 1 TO SET LINE SHUNTS TO ZERO IN POSITIVE SEQUENCE

    2 TO SET LINE SHUNTS TO ZERO IN ALL SEQUENCES:”
Enter 2 and press enter key.

Then PSS/E will give the following option
 “ENTER 1 TO SET TRANSFORMER MAGNETIZING ADMITTANCE TO 0.0 IN POSITIVE    SEQUENCE:”
Enter 1 and press enter key.

Then PSS/E will give the following option
 “ENTER 1 TO ZERO LOAD IN ALL SEQUENCES

ENTER 2 TO ZERO LOAD IN ALL SEQUENCES, AND (GNEG + j BNEG) IN NEGATIVE        SEQUENCE
ENTER 3 TO ZERO LOAD IN ALL SEQUENCES, (GNEG + j BNEG) IN NEGATIVE   SEQUENCE,
AND (GZERO + j BNEG) IN ZERO SEQUENCE:”
Enter 3 and press enter key.

PSS/E will say “Selected flat conditions changes imposed”. At this point close CLI terminal window and then save case. See screenshot for reference.
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Figure 22: PSS/E Command Line Input (CLI) Window with FLAT,CL Command
· Next generate Fault & Relay Data. Run checkascc_revised_01192010.idv to generate the fault data for a particular year. Prior to running checkascc_ revised_01192010.idv, open it and change the pathnames for the folder from which to access the *.sav file and store the SPWG_YYYY_CY/FY_Updated_MMDDYYYY_Faultnew_PassX.dat and SPWG_YYYY_CY/FY_Updated_MMDDYYYY_Relaynew_PassX.dat files into. Before running checkascc_revised_01192010.idv make sure to create SPWG_YYYY_CY/FY_Updated_MMDDYYYY_Relaynew_PassX.dat file in the folder where you would like SPWG_YYYY_CY/FY_Updated_MMDDYYYY_Faultnew_PassX.dat file to be created by PSS/E. There is some error in PSS/E because of which it won’t create SPWG_YYYY_CY/FY_Updated_MMDDYYYY_Relaynew_PassX.dat file automatically.

· After PSS/E creates the SPWG_YYYY_CY/FY_Updated_MMDDYYYY_Faultnew_PassX.dat file, import these files to Fault comparison spreadsheet namely SPWG_YYYY-YYYY_CY/FY_Fault_Comparison_Updated_MMDDYYYY_PassX_FullData.xls via Data ( Import Data.
· Fault comparison is done for each Pass. Fault data entails both Single – Phase and Three – Phase Data obtained from SPWG_YYYY_CY/FY_Updated_MMDDYYYY_PassX_FullData.dat file. This comparison is expressed as a percentage change in the Fault data for a given future year or current year as explained below:

· Current Year Passes: Fault data for the current year is compared to its own data generated as the future – year data in preceding year’s final future – year pass. For example, the Fault Data for the current year 2011 is compared to its own data, when generated as a future – year data in the final pass of 2010. See below for an example.

[image: image26]
· Future Year Passes: Fault data for the 1st future year is compared to the same year’s data as the FY data base in the preceding year. In other words, Fault data for the future year CY + 2 is compared to the Fault data for the future year CY + 1 and so on. Fault data of the year succeeding the current year is compared to its Fault data from the last pass. In other words, Fault data for the future year CY + 1 for the current pass Pass2 is compared to its fault data in the pass Pass1.

[image: image27]
· Once entered into the spreadsheets, the data for all the companies is merged and sorted by the Bus numbers in the ascending order.

· Data of a given bus, for all years stored in their respective columns should be aligned in same row.
· Use the appropriate formulae to calculate the difference in the three – phase and the single – phase fault currents, for a particular bus between two consecutive years and also the respective percentage changes in fault currents (Three – phase and Single phase) for a particular year over its preceding year 
· The fault spreadsheet is now complete and sent to SPWG members for review.
2.7. Final Output – Files Sent to TSPs for Review
· The following files will be sent to SPWG members for their review.

· ASPEN Files

· SPWG_YYYY_CY/FY_Updated_MMDDYYYY_PassX.olr
· SPWG_YYYY_CY/FY_Updated_MMDDYYYY_PassX.DXT

· CompanyAcronym_YYYY_CY/FY_Conversion_From_PSSE_to_ASPEN_PassX.REP

· CompanyAcronym_YYYY_CY/FY_Change_File_Log_PassX.TXT

· SPWG_YYYY_CY/FY_Change_File_Import_Log_Updated_MMDDYYYY_PassX.TXT
· PSS/E Files
· SPWG_YYYY_CY/FY_Updated_MMDDYYYY_PassX.sav

· SPWG_YYYY_CY/FY_Updated_MMDDYYYY_PassX.seq

· SPWG_YYYY_CY/FY_Updated_MMDDYYYY_PassX.raw

· SPWG_YYYY_CY/FY_Islands_Updated_MMDDYYYY_PassX.dat

· Fault Comparison File

· SPWG_YYYY-YYYY_CY/FY_Fault_Comparison_Updated_MMDDYYYY_PassX.xls

2.8. Base Case Building Schedule

· The SPWG and ERCOT determine the CY and FY case building schedules on an annual basis.  The CY case is typically completed by end of March and the FY cases are typically completed by end of June.
3. Modeling Methodologies

3.1. Pre-fault Voltage
· When a linear network solution is used in ASPEN, the prefault bus voltages are calculated using a matrix form of Ohm’s law taking into account all network elements. ERCOT will use generator bus voltages and angles from SSWG summer case of relevant year to update the ref.V and ref.Ang fields in SPWG cases. For example to build SPWG_2015_FY_Updated_ 04112014_Pass0.dxt case, ERCOT shall obtain generator reference voltage and angle from the SSWG summer peak case of year 2015 built as part of SSWG Data Set B case builds.
3.2. Generator Data - Translation of RARF Generator Data Parameters into ASPEN OneLiner

· The table below identifies the mapping of Resource Asset Registration Form (RARF) data parameters into ASPEN OneLiner Generating Unit Info parameters.  Saturated values for Impedances shall be entered into ASPEN OneLiner.  All values are on a per-unit basis on the MVA base provided for the unit. For Current limited generators such as wind turbines of types 3&4, use the Current limit values from RARF.
	RARF Generator Data Parameter
	Acronym
	ASPEN OneLiner Generating Unit Info

	MVA Base
	MVA base
	Unit rating (MVA)

	Saturated Subtransient Reactance
	X’’dv
	Subtransient (jX)

	Saturated Transient Reactance
	X’dv
	Transient (jX)

	Saturated Positive Sequence Z (Saturated Synchronous Reactance)
	Xdv
	Synchronous (jX)

	Saturated Negative Sequence Reactance
	X2v
	- sequence (jX)

	Saturated Zero Sequence Reactance
	X0v
	0 sequence (jX)

	Armature Positive Sequence Resistance
	R1
	Subtransient (R), Transient (R), Synchronous (R)

	Armature Negative Sequence Resistance
	R2
	- sequence (R)

	Armature Zero Sequence Resistance
	R0
	0 sequence (R)

	Instantaneous Controlled Fault Current Magnitude (Multiple of full load current) for Turbine Types 3 & 4
	A
	Current Limit A

	Controlled Fault Current Magnitude At 4 plus cycles after fault (Multiple of full load current) for Turbine Types 3 & 4
	B
	Current Limit B


Table 5: Translation of RARF Generator Data Parameters
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Figure 23: Sample Translation of Generator Data Sheet to ASPEN Generating Unit Info
3.3.  Modeling Wind and Solar Plants in ASPEN OneLiner
· Wind turbine and solar plants are connected to the grid through inverters that dictate the characteristic response during short-circuit fault scenarios. For this reason, they do not act like synchronous or asynchronous machines. Ideally, these sources should be modeled as a current source that mimics the controller characteristics of the inverters. 
· The present methodology in ASPEN Oneliner recommends modeling WTG and PVG using a current-limited generator model. Alternately, Type-4 WTG and PVG may be modeled as Voltage Controlled Current Sources (VCCS). This method is being further developed for the next ASPEN software release. ASPEN Oneliner V15 will include a new generator model for Type-4 WTG and PVG.
3.3.1 Current Limited Generators
· ERCOT models renewable generation with a current limited generator model. Because of the characteristics of these generators, certain modifications are necessary to obtain a suitable approximation. ASPEN provides guidelines for modifying current limited generator models for wind and solar applications. 
· Type-4 wind turbines and solar plants behave in a similar fashion, and are governed entirely by their power electronics and control algorithm. The machines are ungrounded and therefore contribute no zero sequence current. During a fault condition, these machines will initially rise to about 2.5 times full-load current. Within a few cycles, the current will usually settle to 1.1 or 1.2 times full-load current. There will be slight variations between manufacturers and their specific control schemes. Figure 24 shows a typical model for a Type-4 WTG or PVG. The zero sequence impedance is set to j999 pu to prevent zero sequence current. Positive sequence impedance is set to j0.02 pu (not the impedance of the generator). ASPEN also recommends setting the negative sequence impedance to j999 in most cases, as the machines’ controlled response is to limit the flow of negative sequence current. There has been disagreement over the values to use for negative sequence impedance due to its impact on terminal voltage during a fault.
· Type-3 wind turbines are doubly-fed machines, which is a hybrid between a synchronous and induction machine. The behavior of these turbines is therefore more complex. During a close-in fault, high rotor currents cause the machines to “crowbar” to prevent damage to the power electronics. At this point the turbines will act like an induction machine. When the crowbar is not in use, Type-3 turbines will behave similar to Type-4 turbines. Protection studies will need to consider Type-3 turbines with and without current limits to account for both potential scenarios. Figure 25 shows a typical model for a Type-3 WTG. Like Type-4 machines, ASPEN recommends settings Zo to j999. The positive sequence impedance should be set to the transient or sub-transient impedance of the generator. 
[image: image29.png]Generating Unit Info

D=t 1379 Ma

Ipedances (pu based on urit MA)

Subransient|0 +i [om Fil

Trarsent0 ‘i [oz
Synchionous[o W [oz
sequence W e
osequence[8 i [

NeutalImpedance (i actual Ohs)
0 “

Scheduled generation. Enter MVAR for PO buses oy

Mw=[T0. MvAR=[0.
P and O fimits (M and MVAR)
Prax=[110. Oman[16.45
Frin| Qnine] 37,345
Date Inservice: /A Outof-service: Nia
Togs:None

B | (Gl [





Figure 24: Current Limited Generator for Type-4 WTG and PVG
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Figure 25: Current Limited Generator for Type 3 WTG
3.3.2 Current Limited Generator Limitations and Protection Considerations
· The current limited generator model has limited ability to predict post-fault voltages near the generator terminal. This voltage can also be abnormally high when setting negative sequence impedance to j999.
· It is important to have a Y-D-Y high-side MPT modeled from test report data, as this will be the only contribution for ground faults.
· For Type-4 WTG and PVG, current limit B may be more useful for most protection studies, as the instantaneous fault current will typically settle within a few cycles.
· For close-in faults involving Type-3 WTG, it may be desirable to utilize current limit A, or set this current limit to zero to disable it. This will be useful for the crowbar condition. Otherwise, current limit B can be used.
3.4. Transmission Line or Branch Data

· Transmission line/branch data shall be calculated based on TSP’s criteria and entered as per unit values on the nominal kV base. 
3.4.1 Positive Sequence Data

· Positive sequence parameters shall include the impedance and include shunt susceptance where applicable.

3.4.2 Negative Sequence Data

· Negative sequence parameters shall be assumed to be equal to their positive sequence counterparts.  These values are not explicitly entered into the short circuit case.        

3.4.3 Zero Sequence Data 
· Zero sequence parameters shall include the impedance and include shunt susceptance where applicable.

TSPs may opt to model additional parameters as shown below in greater detail as applicable.
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Figure 26: Example of Line Data Entry
3.5. Mutual Impedance Modeling Guidelines

· The impact of mutual impedance on ground fault relaying performance and fault location can be significant and therefore should be included within the short circuit base cases. Absent specific company policies in this area, suggested guidelines for the modeling of mutual impedance effects by ERCOT TSPs are as follows:
· Mutual impedances should be included for circuits sharing a common structure and if the coupled length of adjacent circuits exceeds 10% of the shortest line circuit or if the mutual impedance exceeds 10% of the smallest circuit zero sequence impedance.

· Mutual impedances should be included for circuits sharing a common ROW less than 100 feet wide and if the coupled length of adjacent circuits exceeds 10% of the shortest line circuit or if the mutual impedance exceeds 10% of the smallest circuit zero sequence impedance.
· TSPs may opt to model the mutual impedance of certain circuits in greater detail as warranted.

· In the case of mutual impedances between two circuits owned/operated by different TSPs, the two TSPs shall come to an agreement on which entity shall submit the mutual impedance (“Mutual Pair” in ASPEN OneLiner) information during the annual case building process.  The TSP submitting the data shall be documented in the “Memo” field in ASPEN OneLiner, as shown below.
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Figure 27: Sample Mutual Pair Data
3.6. Coordination of Tie Lines
· A tie line is defined as any transmission circuit with multiple owners represented within the context of the transmission circuit’s associated facility.  Careful coordination and discussion is required among SPWG members to verify the inclusion and accuracy of all modeled tie line data.  Even in situations where no new tie lines are added to a network model, there could be many tie line changes.  Construction timing for future points of interconnection or modified existing points of interconnection can also change and must be monitored.

· It is imperative for neighboring entities to coordinate tie data in order to allow CY and FY work activities to proceed unimpeded. Coordination of tie line data includes timely agreement between entities on the following parameters for each tie line:
· In-service/ out-service dates for ties
· From bus number
· To bus number
· Circuit identifier
· Impedance
· Mutual Impedance
· Transformer adjustment (LTC) data
· Status of branch
· Circuit miles
· Ownership (up to four owners)
· Entity responsible for submitting data  
3.7. Transformer Data
3.7.1 Generator Step-up Transformers

· Wind and solar pad-mount transformers impedances will be in per unit on the transformer’s own base and the tapped value of the voltage.
· Additional modeling guidelines shall be provided as part of a future manual revision. Refer to Appendix A for more information.
3.7.2 Transmission Auto Transformers

· Transformer data shall be obtained from test reports provided by the manufacturer.  If there is no test report for a particular transformer, as can be the case for older legacy units, the TSP must be able to provide the rationale used for determining the parameter values.
· All existing windings of transformers shall be modeled.   A three winding transformer, for example, shall have all of its windings explicitly modeled regardless of whether any winding lacks a load, such as may be the case with a tertiary winding.  
· All impedances may be in per unit on the system MVA base and the tapped value of the voltage.
3.7.2.1 Impedance Data

3.7.2.1.1 Positive Sequence Data
· Positive sequence values should include both the copper losses and leakage reactances for all windings.

3.7.2.1.2 Negative Sequence Data

· Negative sequence parameters should be assumed to be equal their positive sequence counterparts. These values are not explicitly entered into the short circuit case.
3.7.2.1.3 Zero Sequence Data

· Accurate zero sequence data is vital for the proper calculation of current magnitudes for any fault involving a path to ground.  This is the case for all windings (including buried tertiary windings) regardless of whether they are connected to a load. Zero sequence values should include both the resistances and reactances for all windings.
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Figure 28: Example of 2 Winding Data Entry
· 2 Winding Data Entry Guidelines
· MVA1, MVA2, and MVA3 have no effect on any calculations
· MVA base is changeable. 100 MVA is preferred.  Bear in mind that an external case may be using a different value.

· R, X, Ro, and Xo information comes from test report data.

· B and Bo are the magnetizing susceptances.  Rarely used in short circuit calculations.  B can be determined from test report no load data.

· Zg1 is used only if external grounding impedance exists

· The tap values entered should match the voltage from which the transformer impedances are determined.  The bus nominal value, the in-service tap, and the test report tap may not be the same.

· G1, B1, G10, B10, G2, B2, G20, and B20 are shunt admittances and not recommended to be used by ASPEN.

· Use the proper lead or lag configuration for a delta winding.

· “Metered at” is not used (Power Flow Only)

· LTC is not used (Power Flow Only)
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Figure 29: Example of 3 Winding Data Entry
· 3 Winding Data Entry Guidelines
· MVA1, MVA2, and MVA3 have no effect on any calculations

· MVA base is changeable. 100 MVA is preferred.  Bear in mind that an external case may be using a different value.

· Zps, Zpt, Zst, Zps0, Zpt0, and Zst0 information comes from test report data.

· B and Bo are the magnetizing susceptances.  Rarely used in short circuit calculations.  B can be determined from test report no load data.

· Zg1, Zg2, and Zgn are used only if external grounding impedance exists

· The tap values entered should match the voltage from which the transformer impedances are determined.  The bus nominal value, the in-service tap, and the test report tap may not be the same.

· Use the proper lead or lag configuration for a delta winding.

· “Metered at” is not used (Power Flow Only)

· LTC is not used (Power Flow Only)
Note:  All transformer data should be provided by the applicable functional entity as per NERC MOD-32-1 Attachment 1 (“Data Reporting Requirements’)
Appendix A: Wind & Solar Aggregation Techniques
A wind or solar generation plant can be aggregated from a detailed ASPEN model or from the RARF form. Calculations will need to be performed for the padmount transformers and generating units.
· Padmount transformers can be aggregated based on the complex impedance and number of transformers using the following equation:
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Where Z_xfmr is the complex padmount impedance, N is the number of turbines, and MVA_base-xfmr is the power base used for the transformer impedance. MVA_base-new is typically calculated by multiplying the transformer MVA base by the number of transformers, or can be set to 100MVA.  
If a detailed ASPEN model is provided by the generator, it is important to verify the information against the RARF, as they should be congruent. Examples are shown in Figure 30 and Figure 31.
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Figure 30: Padmount Transformer RARF data
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Figure 31: Padmount Transformer ASPEN Model Data
Using the impedances shown above, aggregate impedance values for 60 turbines/transformers would be calculated as:
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Note that by using a 225 MVA base the impedance equation reduces, leaving the aggregate impedances the same as for a single transformer.
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· Generating units can be aggregated from the RARF or a detailed ASPEN model. Generator impedances will be in per-unit at the unit MVA, and will not change for aggregate generators. The “Unit rating MVA” in ASPEN will simply be the unit MVA multiplied by the number of units. MW, MVAR, Pmax, Pmin, Qmax, and Qmin can be calculated the same way, if they are used. These values are not necessary for short circuit modeling calculations, but can be useful if the same model is to be used for PSSE. 
> 2011 CY Pass 1 data with 2011 FY Pass 8 data (created in Year 2010)


> 2011 CY Pass 2 data with 2011 FY Pass 8 data (created in Year 2010)


> 2011 CY Pass 3 data with 2011 FY Pass 8 data (created in Year 2010)


> 2011 CY Pass 4 data with 2011 FY Pass 8 data (created in Year 2010)


> 2011 CY Pass5 FINAL data with 2011 FY Pass 8 data (created in Year 2010)


The comparison of the CY 2011 Pass 1, 2, 3, 4, and 5 with FY 2011 data enables us to observe data 


Progressions with each pass and look for any significant differences between respective passes.





> Comparing 2011 CY (created this Year) with 2012 FY Pass 2 data (created in this Year)


> Comparing 2012 FY Pass 2 data with 2013 FY Pass 2 data


> Comparing 2013 FY Pass 2 data with 2014 FY Pass 2 data 


> Comparing 2014 FY Pass 2 data with 2015 FY Pass 2 data 


Note: We no longer calculate absolute differences between fault currents of two compared   


cases. The resultant +ve or -ve value of the difference indicates whether the current has


increased or decreased over the previous years data. 





From Test Report or RARF





The per unit impedances are based on the tap value





Ensure proper base





Ensure proper configuration
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From Test Report or RARF





Ensure proper base





The per unit impedances are based on the tap value





Ensure proper Δ winding configuration
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